Floatbox update from V6.02 to V8.22

Page: 1

Author Post
Member
Registered: Nov 2013
Posts: 10
Greetings,

Sorry for my apparently stupid question.

i currently have Version 6.02 installed and it apparently works fine, better said, i have not received any complain from visitors.

To update to Version V8.22 which i have downloaded, is it really that i only delete the old V6.02 folder and paste the new V8.22 folder into the root of the website? Of course, the folder name will be identical to the old name...
« Last edit by 22028 on Mon Feb 25, 2019 1:31 pm. »
Administrator
Registered: Aug 2008
Posts: 3359
Greetings 22028. Welcome to Earth. There are no stupid questions here.

In principle, dropping 8.2.2 in place of 6.0.2 should work fine as it responds to the same markup. Floatbox updates have done a pretty good job of remaining backward compatible.

What I can't answer for you is whether or not you have a caching strategy in place that will mitigate against folks continuing to pull components out of their local browser cache, or whether those folks can will encounter any trouble if they do. For example, what might happen if a visitor pulls the new javascript but gets the old floatbox.css from their cache? Probably, things fall apart.

If you're not on top of how cacheing is setup on your site, the safest thing is to give the new floatbox a new folder and change all your include paths to point to the new folder. You may want to do a little a little testing before deciding. If you're happy with how an in-place folder drop works out in your testing, then maybe you're happy going that route.

By the way, your timing is great. 8.2.2 was released just yesterday and to the best of my knowledge is golden and rock-solid. It is likely the last Floatbox release, barring any necessary but unexpected bug-fixes that might crop up.
Member
Registered: Nov 2013
Posts: 10
Tnanks,

I did as advised and it seems to work fine...

Page: 1