.json not loading from Vimeo

Page: 1

Author Post
Member
Registered: May 2012
Posts: 12
Hello,

Please take a look at this webpagetest.org report.

https://www.webpagetest.org/result/180925_Y8_8ecaa49822d70d9755a6c5971e3114f7/1/details/#waterfall_view_step1

You will notice a 404 error loaded by https://www.pifemaster.com/video-floatbox/core.js:0 (floatbox is in a directory named video-floatbox)

Any idea what is going on?

Thank you,
Robert
Administrator
Registered: Aug 2008
Posts: 3350
It's a fetch from vimeo.com. There must be a video link on the page to a vimeo vid that either doesn't exist or that vimeo does not provide a .json info file for.

Here's quoted content from https://floatboxjs.com/options#fetchVideoInfo:
Quote
fetchVideoInfo - true | false
When public videos from Vimeo are configured to show in a floatbox, the Vimeo API service is queried to fetch useful information about the video such as the title, default size, and the path to the video's thumbnail image. This can be set per-item in data-fb-options and per-page or globally.
Vimeo provides API access only for public videos and will not send any info if the video is configured as private on the Vimeo site. Setting fetchVideoInfo:false in these cases can avoid some useless network activity. If the API info is unavailable, the video link's thumbnail, along with size and caption options, will need to be configured manually.
Member
Registered: May 2012
Posts: 12
Thank you very much for the reply. That was the exact information I needed. My videos are not public on Vimeo, so I just needed to globally set fetchVideoInfo:false and this took care of the problem.

Thanks again,
Robert

Page: 1