Slideshow bug

Page: 1

Author Post
Member
Registered: Oct 2017
Posts: 37
The documentation for enableWrap says, "Even when enableWrap is set to false, a slideshow will wrap if started with an item other than #1 or if the afterSlideshow option is set to 'loop'."

I've discovered that this does not seem to be the case. In fact, it produces console errors.

Stripped-down demo: https://misterneutron.com/fbexit

If you start at the first thumbnail and hit Play, it behaves as expected, exiting after the last image. If you start at the first thumbnail and hit Next, then hit Play, it also works fine. But if you start by clicking the 2nd, 3rd, or 4th thumbnail and hit Play, it gets to the last image and stops, rather than exiting. In Chrome, the console complains about Maximum call stack size exceeded. In Firefox, it says Too much recursion.

A similar effect can be seen if you tell FB to loop, rather than exiting: https://misterneutron.com/fbloop

In this case, even manually moving to the 2nd, 3rd, or 4th thumbnail doesn't avoid the error. It happens whenever you hit Play on any image other than the first.

If enableWrap is set to true, things behave properly.

Floatbox 8.1.1.
« Last edit by jGromit on Sun Sep 02, 2018 10:33 pm. »
Administrator
Registered: Aug 2008
Posts: 3350
Good catch. Thanks for reporting it.

The essence of the problem is that doSlideshow:true and enableWrap:false are contradictory, due to the fact that slideshows may need to wrap in order to complete the showing of all items in the group.

This will be fixed in 8.1.2 by forcing enableWrap:true for slideshows.

Page: 1