disable loader animation...

Page: 1

Author Post
Member
Registered: Mar 2017
Posts: 3
I haven't found anything in the docs. Is there a way to disable the loader animation?
Administrator
Registered: Aug 2008
Posts: 3381
Do you mean the little spinning gif image that shows if a resource is slow to load? In my opinion (not that I was asked) it would be a mistake to disable this. The purpose is to give some visual feedback to the user that something is happening in the event of a slow network delay, rather than just letting them think the page has frozen and there's nothing to see here. It shows only after waiting 1.8 seconds for the resource to be fetched.

But I suppose if you did want to remove that slow-load feedback, it should be possible to do so by hiding it with css. Something like the following anywhere in the page's active css should do the trick:
.fbSlowLoad { visibility: hidden !important; }
Member
Registered: Mar 2017
Posts: 3
Thanks, I'll give that a try.
The problem is, the loader never goes away. I"m not even ajax'n in any content. Its all static html referenced by an ID.
Administrator
Registered: Aug 2008
Posts: 3381
Oh! HTML content. The spinner is not shown due to network delay in this case. It is simply placed into the expanding floatbox as it opens because it looks better than having a plain empty rectangle coming up. It should go away when the box is full-sized and can be considered a bug if it does not. I'll look into that for sure.

What version of Floatbox are you using? Perhaps you need to upgrade to the latest/greatest.

If you can see the spinning gif behind your content, then the content must have a transparent background. The easiest way to change that would be to set the contentBackgroundColor option. Never mind fiddling with the CSS recommendation: that would be for slow-loading images.
Member
Registered: Mar 2017
Posts: 3
Yep, setting the BG to white effectively hides it.
I'm told we're using the latest.

Thanks for the quick replies.

Page: 1