Scrolling in Version 7.3

Page: 1

Author Post
Member
Registered: Jan 2012
Posts: 98
Is this a bug, or am I doing something wrong?

I am using 7.3.1 on http://www.myrootsmap.com/. The buttons on the menubar open floatboxes which contain overflowing content. Initially the vertical scroll bar displays correctly but when you try to scroll back from the bottom to the top, the top part of the page is lost. After a couple more attempts at pushing the scrollbar up and down it disappears altogether.

An example of the links is
<a href="examples.php" class="floatbox" data-fb-options="width:750px height:550px maxWidth:90% maxHeight:90% scrolling:auto className:text">Examples</a>

I have tried "scrolling:yes" but that is just the same.
Administrator
Registered: Aug 2008
Posts: 3381
I suspect you're a victim of my bungling the 7.3.1 release. The initial build (2016-06-13) was quickly replaced with a repaired build 2016-06-14.

Please download again to get the fresh build, and let me know if the problem persists. (Don't forget to clear your testing browser cache or use a different install folder name.)
Member
Registered: Jan 2012
Posts: 98
I re-downloaded this morning but the MD5 checksum is the same as the one I was already using (but different from what it says on the download page).

I also tried going back to version 6.1 and the scrolling works fine with that. I've now put everything back to 7.3.1 so that you can see for yourself how it (mis)behaves.

I just checked it with other browsers too. I originally saw the problem on Firefox (V47.0) which is my browser of choice. I've now found it works OK with Edge and Chrome but has more-or-less the same problem with Safari for Windows. <rant> Wouldn't you think that after 25 years of the WWW, all browsers would be able to render a page in the same way?!!!!! </rant>
Member
Registered: Nov 2010
Posts: 71
I just checked out your page. Everything seems to function properly. I can scroll up and down with no loss of data.
Member
Registered: Jan 2012
Posts: 98
Strange. It's still a problem for me in Firefox (not Chrome or Edge). I've tried safe mode and still the same.
Member
Registered: Nov 2010
Posts: 71
Tried in Firefox earlier and it worked fine. Just tried it again in Firefox and now it fails just as you described.
Administrator
Registered: Aug 2008
Posts: 3381
Sounds like you got the 06-14 update on the first download. The quickest way to determine the build number is to type 'fb.build' into a developer console.

I've got the MD5 value synced up to the actual file now - thanks for catching that.

The scrolling weirdness in Firefox and Safari is definitely a browser bug. And yes, it occurs on my demo page too. Try the HTML -> Floatbox Options Reference example in Firefox and notice that you can drag the scrollbar up above the visible scrollbar area and dislocate the document that way.

I've played around a bit, and am sure I can come up with a work-around for this browser bug. It won't be instantaneous as it involves moving scrollbars from the containing element to the iframe itself, using static positioning in some circumstances and absolute in others and, unfortunately, doing different things in different browsers.

I expect 7.3.2 to be ready by next Monday.
Member
Registered: Jan 2012
Posts: 98
Thanks Admin. I realised after writing my previous post that Apple have abandoned Safari for Windows so I'm no longer bothering to test with it. On the other hand Safari for Mac may do the same thing but as I haven't got a Mac I've no way of knowing.

SteveS, I think your first look must have coincided with my test of reverting to Floatbox 6.1. It was only like that for a few minutes and I then put it back to 7.3.1.
Member
Registered: Jan 2012
Posts: 98
I just upgraded to 7.3.2. Problem solved. Now we're cooking with gas!

Page: 1